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MagIC Net 4.1

Release Notes

1 Purpose

This document describes the differences between the new software version
MagIC Net 4.1 and its predecessor MagIC Net 4.0.

2 New features

New devices

889 IC Sample Center

￭ 2.889.0030 889 IC Sample Center Basic
￭ 2.889.0040 889 IC Sample Center Basic - cool

Devices for 2 mm columns

The following devices optimized for 2 mm columns can now be used:

￭ 2.930.2180 Compact IC Flex Oven/Deg/MB
￭ 2.930.2580 Compact IC Flex Oven/SeS/PP/Deg/MB
￭ 2.940.1580 Professional IC Vario ONE/SeS/PP/MB
￭ 2.940.2580 Professional IC Vario TWO/SeS/PP/MB
￭ 2.850.9020 IC Conductivity Detector MB

New columns

New separation columns for anion analysis

￭ 6.01034.410 Metrosep A Supp 19 - 100/4.0
￭ 6.01034.420 Metrosep A Supp 19 - 150/4.0
￭ 6.01034.430 Metrosep A Supp 19 - 250/4.0

New guard columns

￭ 6.01034.500 Metrosep A Supp 19 Guard/4.0

New sample racks

New sample racks for the 858 Professional Sample Processor

The new sample racks are automatically recognized and can be used in
methods:

￭ 6.2041.770 Sample rack 211 x 11 mL
Recommended for high sample throughput.

￭ 6.2041.780 Sample rack 25 x 50 mL + 65 x 11 mL
Sample vessel to be used: bottle PP, 50 mL (6.02743.030)
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New device firmware

Firmware version Devices Comment

5.940.0102 930 Compact IC Flex

940 Professional IC Vario

943 Professional Thermostat / Reactor
Vario

945 Professional Detector Vario

Integration of 850.9020 IC Conduc-
tivity Detector MB.

Firmware update is mandatory.

5.850.0114 850 Professional IC

881 Compact IC pro

882 Compact IC plus

883 Basic IC plus

886 Professional Thermostat / Reactor

896 Professional Detector

920 Absorber Module

Eco IC

Integration of 850.9020 IC Conduc-
tivity Detector MB.

Firmware update is mandatory.

Database program part

New variables

￭ New variables are available for components of calibration standards. The
variables can be found in the formula editor under Results ▶ 'Analysis
name' ▶ Standard'x'. ▶ 'Component name'.

– CONCCALC: Concentration of a standard component calculated with
the calibration used

– CONCDEV%: Percentage deviation of the calculated concentration
from the nominal concentration of a standard component

Method program part

New method templates for anion analysis

￭ The following method templates are available for the new separation col-
umns Metrosep A Supp 19:

– Metrosep A Supp 19 - 100/4.0
7 anions (fluoride, chloride, nitrite, bromide, nitrate, phosphate, sul-
fate)

– Metrosep A Supp 19 - 150/4.0
7 anions (fluoride, chloride, nitrite, bromide, nitrate, phosphate, sul-
fate)

– Metrosep A Supp 19 - 250/4.0
7 anions (fluoride, chloride, nitrite, bromide, nitrate, phosphate, sul-
fate)

Racks for 889 IC Sample Center

￭ In the 889 IC Sample Center, different rack types can now be used in the
left and right rack holders, e.g. 6.2041.200 left and 6.2041.210 right.
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Configuration program part

Firmware update 947 Professional UV/VIS Detector Vario

￭ Now the firmware of 947 Professional UV/VIS Detector Vario can be
updated directly from MagIC Net.

Manual control program part

Racks for 889 IC Sample Center

￭ In the 889 IC Sample Center, different rack types can now be used in the
left and right rack holders, e.g. 6.2041.200 left and 6.2041.210 right.

3 Improvements

General

Current version of the USB driver software

￭ Version 3.60.0 of the USB driver software is installed at the same time as
the installation of MagIC Net 4.1.
With the new driver software, MagIC Net 4.1 can also be installed after the
OMNIS Software has already been installed.

Defective conductivity detector

￭ The message that appears when a conductivity detector is defective has
been made more precise.

Workplace program part

Importing/exporting sample data

￭ Sample data can be imported and exported as CSV files with the Unicode
coding UTF-16BE, UTF-16LE and UTF-8. As a result, all characters are dis-
played correctly in the exported and imported files.

NOTICE

If the import format *.csv (Unicode) was defined in the old MagIC Net ver-
sion under Workplace ▶ Sample table ▶ Properties... ▶ Data import,
then a new import format must be defined by default in the new MagIC Net
version.

Select the same format for importing and exporting sample data.

If the export format is unknown and characters in the sample table are not
displayed correctly, delete the file and re-import it using a different import
format.

Method program part

Displaying methods
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￭ 2 methods can be displayed and edited simultaneously.

Configuration program part

Audit Trail

￭ If the audit trail contains a large number of entries, then the amount of data
may cause performance problems when opening the Audit Trail.
If the number of entries is monitored, then the Audit Trail contains a maxi-
mum of 500,000 entries. The amount of data does not cause any problems.
Metrohm recommends monitoring the number of entries.
If monitoring is not active, then a warning will now appear at 10 million
entries.

PDF not modifiable with 21 CFR Part 11 settings enabled

￭ PDF files created in MagIC Net can be merged without requiring a password
using the Tools ▶ Options... ▶ PDF ▶ Modifying the document
allowed menu item.
However, this is possible only if the Settings according to 21 CFR Part
11 check box is not activated in the Security settings dialog under
Tools ▶ Security settings....

4 Fixed bugs

General

File selection dialog

￭ In the file selection dialog, the context menus of the file folders were not
labeled. The file selection dialog appears if you import data from or export
data to a memory location outside MagIC Net.
For example:

– program part Database  ▶ Tools ▶ Templates ▶ Export tem-
plates... ▶ New ▶ Target directory ▶ ... ▶ Select directory for
export

– Configurationprogram part  ▶ File ▶ Import... ▶ Open

Workplace program part

"Bracketing" calibration mode

￭ Too many standards were used when calibrating with the calibration mode
Bracketing. The standards encompassing the sample in the sample table
were used, as was correct. In addition, all standards that had already been
used for previous samples in the same sample table were reused, which was
wrong.

Database program part

Reprocessing
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￭ An error in connection with the regional Windows settings occurred during
reprocessing.
If the values 1 to 4 were used in a determination, then the determination
could not be opened in the reprocessing table for certain region-dependent
settings of the number formats.
For example: It was mandatory to use the decimal point as decimal separa-
tor.
Now all determinations can be opened, regardless of the regional number
formats.

￭ In a method with multiple analyses, an error occurred when copying com-
ponents. It was not possible to copy components and add them to another
analysis of the same method. The same error also occurred when copying
components in the Method program part (see "Method program part",
page 5).

￭ Too many standards were used when calibrating with the calibration mode
Bracketing. The standards encompassing the sample in the sample table
were used, as was correct. In addition, all standards that had already been
used for previous samples in the same sample table were reused, which was
wrong.

Calibration curve properties

￭ If the Response = f(concentration) function type was selected for the
calibration curve, then incorrect values were specified for Conc.(calc.) and
Conc.(dev.,%).

Database backup

￭ In client/server systems, databases were not always backed up correctly.

Method program part

Copying components

￭ In a method with multiple analyses, an error occurred when copying com-
ponents. It was not possible to copy components and add them to another
analysis of the same method. The same error also occurred during
reprocessing in the Database program part (see "Database program part",
page 4).

Formula editor

￭ The error function was not handled correctly. If there is an error, the numer-
ical value 1 (error present) is generated. Instead, the numerical value 0 (no
error) was generated.

￭ The function Error component name CONC was not executed correctly.
If the component was not calibrated, then an error should be displayed. If
there is an error, the numerical value 1 (error present) is generated. Instead,
the numerical value 0 (no error) was generated.

Configuration program part

Adding columns
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￭ If an automatically recognized column contained invalid characters, then
MagIC Net crashed when the Configuration program part was opened.
The column data is now checked for invalid characters before it is included
in the configuration. If a column contains invalid characters, it will not be
included in the column table.

Archiving the Audit Trail

￭ Once the Audit Trail is exported to a user-defined target directory, the direc-
tory is saved for future archiving. An error occurred if a non-existent target

directory was entered during renewed archiving and then the  icon was
clicked next to the Target directory field.

5 Known bugs

General

Maximizing the window

￭ If you are working with more than one screen and MagIC Net is not open
on the primary screen, then MagIC Net will be moved to the primary screen
when you maximize the window.
Workaround:

– Drag the window to the desired screen.
The window automatically jumps back to the primary screen.

– Minimize the window on the primary screen.
– Press and hold [Alt] while simultaneously clicking on MagIC Net in

the task bar.
The window opens on the screen to which it was moved before mini-
mization.

As an alternative to the workaround described, do not maximize the win-
dow, but simply make it bigger by dragging the margins.

Method program part

Statistics

￭ An error is displayed if the CONCMEAN variable is used as statistics func-
tion.
Correct approach: Only use the CONC variable as statistics function. To
calculate the mean value, select the mean value in the Define statistics
window.

￭ If the CONCMEANSD variable is used as statistics function, the results are
output as invalid during reprocessing.
Correct approach: Only use the CONC variable as statistics function. To
calculate the standard deviation, select the standard deviation in the Define
statistics window.

Tandem dosing
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￭ Tandem dosing requires 2 dosing units. Dosing unit A doses until it is empty.
Then dosing unit A is filled. In the meantime dosing unit B doses. In the
next row, dosing unit A starts again with dosing. Each dosing unit doses
until it is completely empty and is then filled again. So it can happen that
both dosing units are empty at the same time. If dosing cannot be carried
out correctly, the mixing ratio of the gradient changes. To avoid this, pro-
gram the method in such a way that dosing unit B is filled in the beginning
or in the end of each determination.

Monitoring

￭ Common variables cannot be used for monitoring. If common variables are
used for monitoring as Upper limit and Lower limit in a method, then
the limits in a running determination are invalid.

Database program part

Temperature specification

￭ For 930 devices without oven, the Analyses tab in the Information sub-
window shows a temperature of –22.8 °C.

￭ If no column is defined for the analysis in a method, but a temperature is
defined for the device, then the Analyses tab in the Information sub-
window shows no temperature. Therefore always assign a column to the
analysis.

Monitoring

￭ A lower limit and an upper limit are defined for monitored determinations.
If the result is outside of the defined limits, then a message is displayed on
the Messages tab in the Information subwindow. If the determination is
then recalculated with changed limits and the result is within the limits,
then the message will nonetheless be displayed.

6 Compliance

The current software version does not contain any modifications that affect
conformity of MagIC Net regarding 21 CFR Part 11 or its classification into the
GAMP software category.
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